package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)[^\/]*(\/[^\/]*)`)
var str = `/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX/benefitlist
/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/excluded`
var substitution = "\1XXXX\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}