import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\/[^\\/]*\\/[^\\/]*\\/[^\\/]*\\/[^\\/]*\\/[^\\/]*\\/)[^\\/]*(\\/[^\\/]*)";
final String string = "/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX/benefitlist\n"
+ "/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX-/excluded\n"
+ "/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/benefitlist\n"
+ "/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/excluded\n"
+ "/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/benefitlist\n"
+ "/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/excluded\n"
+ "/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/benefitlist\n"
+ "/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/excluded";
final String subst = "\\1XXXX\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}