import re
regex = re.compile(r"^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)[^\/]*(\/[^\/]*)", flags=re.MULTILINE)
test_str = ("/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX/benefitlist\n"
"/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX-/excluded\n"
"/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/benefitlist\n"
"/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/excluded\n"
"/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/benefitlist\n"
"/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/excluded\n"
"/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/benefitlist\n"
"/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/excluded")
subst = "\\1XXXX\\2"
result = regex.sub(subst, test_str)
if result:
print(result)