// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/[^\/]*\/)[^\/]*(\/[^\/]*)").unwrap();
let string = "/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX/benefitlist
/v1/cp/members/XXXX/benefits/XXXXBG-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXUF-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXUU-XXXX-XXXX-/excluded
/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/benefitlist
/v1/cp/members/XXXX/benefits/XXXXXXXX-XXXX-XXXX-/excluded";
let substitution = "\\1XXXX\\2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}