#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\r|\n| |\t)+\<Grid(\r|\n| |\t)+Grid\.Row="0"(\r|\n| |\t)+IsVisible="False"(\r|\n| |\t)+Style="\{StaticResource(\r|\n| |\t)+MadressahFilterPickerGridBackgroundStyle\}"\>"
Local $sString = " <Grid Grid.Row="2" Grid.Column="2" RowSpacing="0">" & @CRLF & _
" <Grid.RowDefinitions>" & @CRLF & _
" <RowDefinition Height="Auto" />" & @CRLF & _
" </Grid.RowDefinitions>" & @CRLF & _
" <Grid Grid.Row="0" Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">" & @CRLF & _
" <StackLayout Orientation="Horizontal">" & @CRLF & _
" <StackLayout.GestureRecognizers>" & @CRLF & _
" <TapGestureRecognizer Tapped="ParentTapGestureRecognizer_Tapped" />" & @CRLF & _
" </StackLayout.GestureRecognizers>" & @CRLF & _
" <Label x:Name="parentName" Text="{Binding ParentPicker}"" & @CRLF & _
" BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}"" & @CRLF & _
" Style="{StaticResource MadressahFilterPickerLabelStyle}" LineBreakMode="NoWrap"/>" & @CRLF & _
" <Label Style="{StaticResource MadressahPickerArrowStyle}" />" & @CRLF & _
" </StackLayout>" & @CRLF & _
" </Grid>" & @CRLF & _
" <Grid Grid.Row="0" IsVisible="False"" & @CRLF & _
" Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">" & @CRLF & _
" <Picker x:Name="parentList" Title="{i18n:Translate selectparent}"" & @CRLF & _
" ItemsSource="{Binding ParentList}"" & @CRLF & _
" ItemDisplayBinding="{Binding FullName}"" & @CRLF & _
" SelectedItem="{Binding ParentSelected}"" & @CRLF & _
" BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}" />" & @CRLF & _
" </Grid>" & @CRLF & _
" </Grid>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")