import Foundation
let pattern = #"(\r|\n| |\t)+\<Grid(\r|\n| |\t)+Grid\.Row="0"(\r|\n| |\t)+IsVisible="False"(\r|\n| |\t)+Style="\{StaticResource(\r|\n| |\t)+MadressahFilterPickerGridBackgroundStyle\}"\>"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<Grid Grid.Row="2" Grid.Column="2" RowSpacing="0">
<Grid.RowDefinitions>
<RowDefinition Height="Auto" />
</Grid.RowDefinitions>
<Grid Grid.Row="0" Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">
<StackLayout Orientation="Horizontal">
<StackLayout.GestureRecognizers>
<TapGestureRecognizer Tapped="ParentTapGestureRecognizer_Tapped" />
</StackLayout.GestureRecognizers>
<Label x:Name="parentName" Text="{Binding ParentPicker}"
BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}"
Style="{StaticResource MadressahFilterPickerLabelStyle}" LineBreakMode="NoWrap"/>
<Label Style="{StaticResource MadressahPickerArrowStyle}" />
</StackLayout>
</Grid>
<Grid Grid.Row="0" IsVisible="False"
Style="{StaticResource MadressahFilterPickerGridBackgroundStyle}">
<Picker x:Name="parentList" Title="{i18n:Translate selectparent}"
ItemsSource="{Binding ParentList}"
ItemDisplayBinding="{Binding FullName}"
SelectedItem="{Binding ParentSelected}"
BindingContext="{ Binding Source={x:Reference Root}, Path=BindingContext}" />
</Grid>
</Grid>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)