use strict;
my $str = '
M/20/5\'10" [150lbs to 180lbs] (2 years; 6 months) + (B: 300lbs; S: 410lbs; D: 480lbs)
F/26/5\'2" [52kg to 59kg] (5 years)
M/35/6\'3" [203lbs to 175lbs] (7 months) - Additional comments here
M/20/5\'10" [150lbs to 180lbs] (2 years; 6 months) + (B: 300lbs; S: 410lbs; D: 480lbs) ';
my $regex = qr/([M,F]\/\d{2}\/((\d{1}((\')|(\’))?(([0,2-9]|1[0-1]?)((\")|(\'\')|(\”))?)?)|\d{1,3}cm|[1-2]m(\d{1,2}(cm)?)?)\s?\[\d{2,3}\s?(lbs|kg)\s?to\s?\d{2,3}\s?(lbs|kg)\]\s?\(((\d{1,2}\s?years?)|(([2-9]|1[0-1]?)\s?months?)|(\d{1,2}\s?years?(\;|\,)?\s?([0,2-9]|1[0-1]?)\s?months?)|(([2-9]|1[0-1]?)\s?weeks?))\)\s?(\s?\+\s?\(([DSBO]{1}:\s?(\d{2,3})\s?(lbs|kg)(\;|\,))?\s?([DSBO]{1}:\s?(\d{2,3})\s?(lbs|kg)(\;|\,))?\s?([DSBO]{1}:\s?(\d{2,3})\s?(lbs|kg)(\;|\,))?\s?[DSBO]{1}:\s?(\d{2,3})\s?(lbs|kg)\))?.*)|(^\[Meta\].*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}