using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d{1,6}(?:-\d{0,4})?$";
string input = @"123456-1234
123456-123
123456-12
123456-1
123456-
123456
12345
1234
123
12
1
-
-1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}