// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d{1,6}(?:-\d{0,4})?$").unwrap();
let string = "123456-1234
123456-123
123456-12
123456-1
123456-
123456
12345
1234
123
12
1
-
-1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}