# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(# .+?\\n)(.+)/\1/;t' <<< "# Title\n## Chapter\n### sub-chapter#### The Bar\nIt was a fall day.\n"