#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(# .+?\\n)(.+)"
Local $sString = "# Title\n## Chapter\n### sub-chapter#### The Bar\nIt was a fall day.\n"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)