package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(# .+?\\n)(.+)`)
var str = []byte(`# Title\n## Chapter\n### sub-chapter#### The Bar\nIt was a fall day.\n`)
var substitution = []byte("\1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}