use strict;
my $str = '# Title\\n## Chapter\\n### sub-chapter#### The Bar\\nIt was a fall day.\\n';
my $regex = qr/(# .+?\\n)(.+)/p;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";