#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?<=Amount Due|Pay This Amount|Total Balance|Total Current Month’s Charges|Amount Now Due|Amount Due|Amount due on|Total Balance on)\s+(\w+)?\s?\$([\d.,]+)"
Local $sString = "Pay this amount $45.50" & @CRLF & _
"" & @CRLF & _
"Pay this amount due Mar04 $56.67 → Does not work with current expression" & @CRLF & _
"" & @CRLF & _
"Amount due $56.78 → works with current expression" & @CRLF & _
"" & @CRLF & _
"Amount due on dec4 $76.45 → does not work with current expression" & @CRLF & _
"" & @CRLF & _
"Total balance $76.45 → works with current expression" & @CRLF & _
"" & @CRLF & _
"Total balance on apr3 $64.34"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")