import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Amount Due|Pay This Amount|Total Balance|Total Current Month’s Charges|Amount Now Due|Amount Due|Amount due on|Total Balance on)\\s+(\\w+)?\\s?\\$([\\d.,]+)";
final String string = "Pay this amount $45.50\n\n"
+ "Pay this amount due Mar04 $56.67 → Does not work with current expression\n\n"
+ "Amount due $56.78 → works with current expression\n\n"
+ "Amount due on dec4 $76.45 → does not work with current expression\n\n"
+ "Total balance $76.45 → works with current expression\n\n"
+ "Total balance on apr3 $64.34";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}