import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(.*?)(?:\\s+v[0-9]+|\\s+vol\\.?\\s*[0-9]+)";
final String string = "This is what I want v1\n"
+ "This is what I want Vol.27\n"
+ "This is what I want vol 1\n"
+ "This is what I want VOL. 27\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}