# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r":[^,]*,"
test_str = ("open: boolean,\n"
" onDidDismiss: () => void,\n"
" message: string,\n"
" showAddReceiptModal: boolean,\n"
" showModal: (value: (((prevState: boolean) => boolean) | boolean)) => void,\n"
" vehicleTabRef: React.MutableRefObject<null>,\n"
" onReceiptSubmit: (data) => void,\n"
" vehicle: any,\n"
" showModal1: boolean,\n"
" showModal2: (value: (((prevState: boolean) => boolean) | boolean)) => void,\n"
" selectedReceipt: { __typename: \"Receipt\" | undefined; id: string | undefined; purchaseDate: string | undefined; sellerName: string | undefined; sellerAddress: string | undefined; sellerCity: string | undefined; sellerState: string | undefined; sellerZipCode: string | undefined; totalAmount: number | undefined; gallonsPurchased: number | undefined; image?: string | null | undefined | undefined; userID?: string | null | undefined | undefined; vehicleID: string | undefined; vehicle?: Vehicle | null | undefined | undefined; taxRefund?: number | null | undefined | undefined; createdAt: string | undefined; updatedAt: string | undefined },\n"
" onClick: () => void,\n"
" onClick1: () => void,\n"
" dataEditing: boolean,\n"
" toastMessage: (val) => void,\n"
" editing: (bool) => void,\n"
" showToast: (bool) => void,\n"
" showModal3: boolean,\n"
" showModal4: (bool) => void,\n"
" dateFilter: { startDate: string; endDate: string },")
subst = ","
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.