re = /\([0-9]\)\s+([^.!?]+[.!?])/
str = '(1) This is my first sentence, it has to be captured. This is my second sentence.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end