#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "((([^ ]+) +(me debe) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))"
Local $sString = "Anota que le debo 3€ a Antonio " & @CRLF & _
"Anota que le debo 3€ a Antonio del Monster" & @CRLF & _
"Anota que le debo 3€ del Monster a Antonio " & @CRLF & _
"Anota que @EsclavoDeLaLuna me debe 6 euros del monster"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")