const regex = new RegExp('((([^ ]+) +(me debe) +(\\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?)|((le debo) +(\\d+) *([^ ]+)? *(a ([^ ]+)) *((del?|por ?e?l?) +(.+))?)|((le debo) +(\\d+) *([^ ]+)? *((del?|por ?e?l?) +(.+))?(a ([^ ]+))))', 'g')
const str = `Anota que le debo 3€ a Antonio
Anota que le debo 3€ a Antonio del Monster
Anota que le debo 3€ del Monster a Antonio
Anota que @EsclavoDeLaLuna me debe 6 euros del monster`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}