# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[[:space:]]|(?=(?![',])[[:punct:]])/\n/g;t' <<< "I'm not that good at regex yet, but am getting better!"