using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[[:space:]]|(?=(?![',])[[:punct:]])";
string substitution = @"\n";
string input = @"I'm not that good at regex yet, but am getting better!";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}