use strict;
my $str = 'I\'m not that good at regex yet, but am getting better!';
my $regex = qr/[[:space:]]|(?=(?![',])[[:punct:]])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";