const regex = /\D\d{3}\s?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D\\d{3}\\s?', 'g')
const str = `4473 333hello 564 394844he hello
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}