// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(public|)\s+(?<type>[^\s]+)\s+(?<name>[^\s]+)\s*\{(\s*(get|set)\s*;){2}\s*\}").unwrap();
let string = "public TypeName PropertyName { get; set; }";
let substitution = "public static readonly DependencyProperty ${name}Property = DependencyProperty.Register(\"${name}\", typeof(${type}), typeof(DependencyObjectType), new PropertyMetadata(default(${type}), ${name}Changed));\\nprivate static void ${name}Changed(DependencyObject dependencyObject, DependencyPropertyChangedEventArgs dependencyPropertyChangedEventArgs)\\n{\\nvar dependencyObjectType = dependencyObject as DependencyObjectType;\\nif(dependencyObjectType == null)\\nreturn;\\nvar oldValue = (${type})dependencyPropertyChangedEventArgs.OldValue;\\nvar newValue = (${type})dependencyPropertyChangedEventArgs.NewValue;\\n/* Logic... */\\n}\\n/// <summary>\\n/// ${name}\\n/// </summary>\\npublic ${type} ${name}\\n{\\nget { return (${type})GetValue(${name}Property); }\\nset { SetValue(${name}Property, value); }\\n}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}