package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^>]+>$`)
var str = `Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}