use strict;
my $str = 'Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
';
my $regex = qr/[^>]+>$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";