import Foundation
let pattern = #"[^>]+>$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
Str$#$ing1>Stri$#$ng2>String3>Stri#$$#ng4>St#$#$ring5>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)