#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-zA-Z\.-]{2,}"
Local $sString = "example.com=120.0.0.0" & @CRLF & _
"ben.example.com=120.0.0.0" & @CRLF & _
"+ben.example=120.0.0.0" & @CRLF & _
"+ben-example.com.np=120.0.0.0" & @CRLF & _
"ben=120.0.0.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")