$re = '/^[0-9]+([,.][0-9]{2,2})?$/';
$str = '21,52';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);