#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?i).*([a-z]{4}\.[a-z]{5}).*as\s+([a-z]+).*"
Local $sString = "cast (mara.attyp as prodcategory preserving type ) as ProductCategory"
Local $sSubst = "$1 $2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)