import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https://rextester.com/JFUKE76014";
final String string = "COINGBIT \n"
+ "Commit fb5aa46\n"
+ "to 0x9d9b6f05d7b72588f83cc60fda4286ba45d13924\n\n"
+ "Nonce 6324\n"
+ "Rash 0xa964e1ee4c92c25f47392f67b735095304631089b5f2173825b7e93f49f08d57\n"
+ "Bloco 3391586\n"
+ "valor=us$ 7.000.000.000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}