import re
regex = re.compile(r"(P\w+)\W(P\w+)", flags=re.MULTILINE)
test_str = ("Python PHP\", \"Java JavaScript\", \"c c++\"\n\n"
"(P\\w+)\\W(P\\w+)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")