using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/collections\/((hand-knit-dolls)|(gift-bundles)|(inspirational-prints)|(.*upsell)|(all))\/products\/";
string input = @"https://cuddleandkind.com
https://cuddleandkind.com/collections/hand-knit-dolls
https://cuddleandkind.com/collections/gift-bundles
https://cuddleandkind.com/collections/inspirational-prints
https://cuddleandkind.com/collections/all
https://cuddleandkind.com/collections/harlow-upsell
https://cuddleandkind.com/collections/hand-knit-dolls/products/harlow-the-swan
https://cuddleandkind.com/collections/gift-bundles/products/dreamy-easter-bundle
https://cuddleandkind.com/collections/gift-bundles/products/somebunny-loves-you-bundle
https://cuddleandkind.com/collections/inspirational-prints/products/harlows-print
https://cuddleandkind.com/collections/harlow-upsell/products/harlows-print
https://cuddleandkind.com/collections/harlow-print-upsell/products/harlow-the-swan
https://cuddleandkind.com/collections/all/products/chloe-the-bunny?variant=12747230969968
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}