const regex = /\/collections\/((hand-knit-dolls)|(gift-bundles)|(inspirational-prints)|(.*upsell)|(all))\/products\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/collections\\\/((hand-knit-dolls)|(gift-bundles)|(inspirational-prints)|(.*upsell)|(all))\\\/products\\\/', 'gm')
const str = `https://cuddleandkind.com
https://cuddleandkind.com/collections/hand-knit-dolls
https://cuddleandkind.com/collections/gift-bundles
https://cuddleandkind.com/collections/inspirational-prints
https://cuddleandkind.com/collections/all
https://cuddleandkind.com/collections/harlow-upsell
https://cuddleandkind.com/collections/hand-knit-dolls/products/harlow-the-swan
https://cuddleandkind.com/collections/gift-bundles/products/dreamy-easter-bundle
https://cuddleandkind.com/collections/gift-bundles/products/somebunny-loves-you-bundle
https://cuddleandkind.com/collections/inspirational-prints/products/harlows-print
https://cuddleandkind.com/collections/harlow-upsell/products/harlows-print
https://cuddleandkind.com/collections/harlow-print-upsell/products/harlow-the-swan
https://cuddleandkind.com/collections/all/products/chloe-the-bunny?variant=12747230969968
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}