// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\/collections\/((hand-knit-dolls)|(gift-bundles)|(inspirational-prints)|(.*upsell)|(all))\/products\/").unwrap();
let string = "https://cuddleandkind.com
https://cuddleandkind.com/collections/hand-knit-dolls
https://cuddleandkind.com/collections/gift-bundles
https://cuddleandkind.com/collections/inspirational-prints
https://cuddleandkind.com/collections/all
https://cuddleandkind.com/collections/harlow-upsell
https://cuddleandkind.com/collections/hand-knit-dolls/products/harlow-the-swan
https://cuddleandkind.com/collections/gift-bundles/products/dreamy-easter-bundle
https://cuddleandkind.com/collections/gift-bundles/products/somebunny-loves-you-bundle
https://cuddleandkind.com/collections/inspirational-prints/products/harlows-print
https://cuddleandkind.com/collections/harlow-upsell/products/harlows-print
https://cuddleandkind.com/collections/harlow-print-upsell/products/harlow-the-swan
https://cuddleandkind.com/collections/all/products/chloe-the-bunny?variant=12747230969968
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}