import Foundation
let pattern = #"\/collections\/((hand-knit-dolls)|(gift-bundles)|(inspirational-prints)|(.*upsell)|(all))\/products\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://cuddleandkind.com
https://cuddleandkind.com/collections/hand-knit-dolls
https://cuddleandkind.com/collections/gift-bundles
https://cuddleandkind.com/collections/inspirational-prints
https://cuddleandkind.com/collections/all
https://cuddleandkind.com/collections/harlow-upsell
https://cuddleandkind.com/collections/hand-knit-dolls/products/harlow-the-swan
https://cuddleandkind.com/collections/gift-bundles/products/dreamy-easter-bundle
https://cuddleandkind.com/collections/gift-bundles/products/somebunny-loves-you-bundle
https://cuddleandkind.com/collections/inspirational-prints/products/harlows-print
https://cuddleandkind.com/collections/harlow-upsell/products/harlows-print
https://cuddleandkind.com/collections/harlow-print-upsell/products/harlow-the-swan
https://cuddleandkind.com/collections/all/products/chloe-the-bunny?variant=12747230969968
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)