package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(E|EC|N|NW|SE|SW|W|WC|BR|CR|DA|EN|HA|IG|SL|TN|KT|RM|SM|TW|UB|WD|CM)`)
var str = `E1 7AA
E1 7AD
M1 1AG`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}