using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?!\s)([A-Z\sÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]{4,})\b[^A-ZÀÈÌÒÙÁÉÍÓÚÝÂÊÎÔÛÃÑÕÄËÏÖÜŸ]*CPF.*?(\d{3}.\d{3}.\d{3}.\d{2})";
string input = @"NOT THIS NAME, blah blah, ETC ETC ETC, XXXX 00.000.000/0001-00, blah blah, 123, ZIP 12345-123, blah blah, blah TEXT TEXT TEXT TEXT, blah blah THIS NAME, blah blah, blah blah CPF 999.999.999-99 blah blah";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}