import Foundation
let pattern = #"^(\S+)(\S*?)\s+?(\S*?(\1)\S*?)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
ABCD 19475ABCD_97jdhgbl
ABCD 19475ABC_97jdhgbl
CDEF 87437862AB83742kh
が増える 値段がが増える
上げる 彼は荷物をあみだなに上げた。
ABCDABCD ABCD
務める ああうるさい務めすは苦手で
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)