#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)# the opening delimiter
" & @CRLF & _
"(["'])
" & @CRLF & _
"# the body is
" & @CRLF & _
"(?:
" & @CRLF & _
" # either an escaped delimiter
" & @CRLF & _
" \\\1
" & @CRLF & _
" # or
" & @CRLF & _
" |
" & @CRLF & _
" # anything except a backslash or a delimiter
" & @CRLF & _
" (?!\\|\1).
" & @CRLF & _
" # (can't put \1 in a character class, so use a negative lookahead)
" & @CRLF & _
")*
" & @CRLF & _
"# repeated zero or more times# the closing delimiter
" & @CRLF & _
"\1"
Local $sString = "{if Server:GetPhpSelf == "/ind'ex.php"}" & @CRLF & _
"foo 'hhhh"hhh""hhh' plonk" & @CRLF & _
"foo "meep\"meep" plonk" & @CRLF & _
"foo 'meep\'meep' plonk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")