package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SushiRoles.*:.*\"MMa\"`)
var str = `<AuthZ><PersonaId:"1090553942"></PersonaId><SushiRoles 123:abc "MMa"></SushiRoles><R:"1090553939">`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}