package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((www\.|(http|https|ftp|news|file)+\:\/\/)?[_.a-zA-Z0-9-]+\.[a-zA-Z0-9\/_:@=.+?,##%&~-]*[^.|\'|\#|\(|?|,| |>|<|;|\)]*)`)
var str = `bla1 bla2 http://www.peckale.com/#!contact/c11m6 bla3`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}