const regex = new RegExp('<wp:postmeta>[\\s\\S]*?</wp:postmeta>', 'g')
const str = `<wp:postmeta><wp:meta_key>_edit_last</wp:meta_key><wp:meta_value><![CDATA[2]]></wp:meta_value></wp:postmeta>
<wp:postmeta><wp:meta_key>seo_follow</wp:meta_key><wp:meta_value><![CDATA[false]]></wp:meta_value></wp:postmeta>
<wp:postmeta>
<wp:meta_key>seo_noindex</wp:meta_key>
<wp:meta_value><![CDATA[false]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_focuskw</wp:meta_key>
<wp:meta_value><![CDATA[services de proximité, transports de marchandises]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_title</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>
<wp:postmeta>
<wp:meta_key>_yoast_wpseo_metadesc</wp:meta_key>
<wp:meta_value><![CDATA[]]></wp:meta_value>
</wp:postmeta>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}