using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Tool Call[ ]{0,2}\K[0-9]+|Tool Call[ ]{0,2}\K[\""][0-9]+[\""]|Tool Call[ ]{0,2}\K[\""]?...[\""]";
string input = @"Tool Call ""04561""
Tool Call 1613 S1261
Tool Call 4301480
Tool Call ""ABE"" F94916
Tool Call S161300
Tool Call F26161";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}