# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"{\s*[\"']\s*streamUrl\s*[\"']\s*:\s*[\"']\s*(http[^\"']+)"
test_str = ("\"language\":[\"Français\"],\"logo100x100\":\"http://static.radio.fr/images/broadcasts/15/43/8275/1/c100.png\",\n"
"\"streamUrls\":[{\"streamUrl\":\"http://mp3lg4.tdf-cdn.com/9243/lag_164753.mp3\",\"loadbalanced\":false,\n"
"\"metaDataAvailable\":false,\"playingMode\":\"STEREO\",\"type\":\"STREAM\",\"sampleRate\":44100,\"streamContentFormat\":\"MP3\",\n"
"\"bitRate\":128,\"idBroadcast\":8275,\"sortOrder\":0,\"streamFormat\":\"ICECAST\",\"id\":47609,\"streamStatus\":\"VALID\",\n"
"\"contentType\":\"audio/mpeg\"},{\"streamUrl\":\"http://mp3lg3.scdn.arkena.com/10490/virginradio.mp3\",\"loadbalanced\":false,\n"
"\"metaDataAvailable\":false,\"playingMode\":\"STEREO\",\"type\":\"STREAM\",\"sampleRate\":44100,\"streamContentFormat\":\"MP3\",\n"
"\"bitRate\":64,\"idBroadcast\":8275,\"sortOrder\":1,\"streamFormat\":\"ICECAST\",\"id\":57003,\"streamStatus\":\"VALID\",\n"
"\"contentType\":\"audio/mpeg\"}],\"playable\":\"PLAYABLE\",\"genres\":[\"Pop\",\"Rock\"],\n"
"\"logo175x175\":\"http://static.radio.fr/images/broadcasts/15/43/8275/1/c175.png\",\"\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.