package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`goTo(_[\S_]+){3}`)
var str = `param-out goTo goTo_6f7aaaab-8a2b-4654-9a51-eb590ec0f2b4_1_ddb34756-8194-4e5a-8aa9-12a755eff6c1 goTo-1
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}