$re = '/goTo(_[\S_]+)(_[\S_]+)(_[\S_]+)/';
$str = 'param-out goTo goTo_6f7aaaab-8a2b-4654-9a51-eb590ec0f2b4_1_ddb34756-8194-4e5a-8aa9-12a755eff6c1 goTo-1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);