const regex = /^[^ #;\[]{77}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^ #;\\[]{77}$', 'gm')
const str = `lets_make_a_snake<-function(n)\`for\`(i,1:n,cat(i*n+1-\`if\`(i%%2,n:1,1:n),"\\n"))
invisible(sapply(1:(n=scan()),function(i)cat(i*n+1-\`if\`(i%%2,n:1,1:n),"\\n")))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}