re = /^[^ #;\[]{77}$/m
str = 'lets_make_a_snake<-function(n)`for`(i,1:n,cat(i*n+1-`if`(i%%2,n:1,1:n),"\\n"))
invisible(sapply(1:(n=scan()),function(i)cat(i*n+1-`if`(i%%2,n:1,1:n),"\\n")))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end